Информатика, вопрос задал mumu1779 , 1 год назад

Помогите срочно написать программу на Python!!

Нужно написать программу , где пользователь вводит 2 числа .И программа выводит сумму цифр от первого до второго числа.

Например: Программа просит ввести два числа .
Пользователь: вводит например:4 и 10
И программа выводит сумму чисел от первого числа до второго(5+6+7+8+9)

(Даю 30 баллов)

Ответы на вопрос

Ответил Ivan19074
1

Ответ:

x = int(input())

y = int(input())

print((y-1)*y//2 - x*(x+1)//2)

Объяснение:

Чтобы вывести сумма от х до у, есть хитрая формула. Это (y-1)*у/2 - x*(x+1)/2. Например, чтобы вычислить сумму чисел от 2 до 6, получим 12, и это правильный ответ.

Теперь сама программа:

``` (Python)

x = int(input())

y = int(input())

print((y-1)*y//2 - x*(x+1)//2)

```

Она работает, я проверил

Ответил p15
0

Ответ:

Сделаю тебе с циклом, а то учитель не одобрит, хотя действительно можно использовать формулу для арифметической прогрессии.

a=int(input('начало='))

b=int(input('конец='))

s=0

if a>b: a,b=b,a

for i in range(a+1,b):

 s+=i

print(f'сумма от {a} до {b}, их не включая равна {s}')

Объяснение:

В программе предусмотрено, если ты ошибся и сначала ввел конец, а потом начало

Приложения:
Новые вопросы