Информатика, вопрос задал Sveta67 , 10 лет назад

Помогите!СРОЧНО!!!

Надо составить программу для Паскаль ABC

Дано вещественное число.Если оно отрицательное, вывести на экран его модуль, а если нет, то вычислить из него квадратный корень. 

Ответы на вопрос

Ответил sansanic
0

var

  a: real; 

 

begin

  writeln('Введите вещественное число');

  readln(a);  //Вводим вещественное число

  if a < 0 then writeln('Модуль числа а: ', abs(a))  {Если введенное число - отрицательное, печатаем его модуль, иначе печатаем квадратный корень из этого числа с округлением до 5 знаков после запятой}

  else writeln('Квадратный корень из числа а: ', sqrt(a) : 0 : 5);

end.

Новые вопросы