Помогите срочно, даю 15 баллов
Напишите программу, которая удаляет из строки N символов с конца.
Ответы на вопрос
Ответил Maximason
0
uses crt;
var s: string;
n,q :integer;
begin
while n=0 do begin
writeln ('Введите строку ');
readln (s);
n:=length(s);
clrscr;
end;
writeln('сколько символов нужно удалить из ',s,' ?');
read (q);
if q>n
then begin writeln ('символов для удаления больше, чем существует');
s:=''; end
else
delete (s,((n+1)-q),q+1);
write (s);
end.
P.s. Программа написана на языке Pascal ABC.
var s: string;
n,q :integer;
begin
while n=0 do begin
writeln ('Введите строку ');
readln (s);
n:=length(s);
clrscr;
end;
writeln('сколько символов нужно удалить из ',s,' ?');
read (q);
if q>n
then begin writeln ('символов для удаления больше, чем существует');
s:=''; end
else
delete (s,((n+1)-q),q+1);
write (s);
end.
P.s. Программа написана на языке Pascal ABC.
Новые вопросы