ПОМОГИТЕ СРОЧНО 2 ПО ИНФОРМАТИКЕ ВЫХОДИТ!
Написать программу для задачи: "Найти произведение максимального и минимального элементов массива из 5 чисел, заданных случайным образом "
Ответы на вопрос
Ответ:
Объяснение:
const sizeArr = 5; // Размер массива
var
a: array [1..sizeArr] of integer;
i: integer;
maxElem: integer; // Максимальный элемент
minElem: integer; // Минимальный элемент
multMinMax: integer; // Произведение элементов
begin
// Инициализация переменных
maxElem := 0;
minElem := 100;
multMinMax := 0;
// Заполнение массива случайными числами
// И определение максимального и минимального элементов
randomize();
for i:=1 to sizeArr do
begin
a[i] := random(100);
if (a[i] > maxElem)then
maxElem := a[i];
if (a[i] < minElem) then
minElem := a[i];
end;
// Произведение максимального и минимального элементов
multMinMax := maxElem * minElem;
// Вывод
write('multMinMax = ', multMinMax);
readln();
end.