Помогите, срочно!!
1. Написать программу суммирующую числа до тех пор пока не будет введён "0".
Входные данные:
1 2 3 0
Выходные данные:
6
2. Написать программу поиска НОД (Наибольший Общий Делитель) двух чисел.
Входные данные:
170 42
Выходные данные:
2
pavlikpetrov1994:
На языке Pascal
Ответы на вопрос
Ответил tolkuevgg
1
1)
program g;
var
a, b, c, d:integer;
begin
Readln(a, b, c, d) ;
begin
if a = 0 then
Writeln('0') end ;
begin
if b = 0 then
Writeln(a) end ;
begin
if c = 0 then
Writeln(a + b) end ;
begin
if d = 0 then
Writeln(a + b + c) end ;
end.
Новые вопросы
Українська мова,
1 год назад
Литература,
1 год назад
Математика,
1 год назад
Английский язык,
7 лет назад