Информатика, вопрос задал feldman2001 , 8 лет назад

Помогите создать программу Python
Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Пример:
Введите два числа: 10 -15
10*(-15)=-150

Ответы на вопрос

Ответил srzontmp
0
a=int(input('a = '));
b=int(input('b = '));
if (((a<0) & (b>0)) | ((a>0) & (b<0))): sgn=1;
else: sgn=0;
if (a<0): a=-a;
if (b<0): b=-b;
c=0;
while (a>0):
    if ((a & 1)==1): c+=b;
    a>>=1;
    b<<=1;
if (sgn==1): print('результат: ',-c);
else: print('результат: ',c);

a = - 42153689754
b = 7892456310201
результат:  - 332696154697212539380554
    
Новые вопросы