Информатика, вопрос задал joker523 , 7 лет назад

Помогите составить программу вычисления функций под номером 4.

Приложения:

Ответы на вопрос

Ответил fedrfedr
0

uses Math;

var

 y, f: real

begin

   Write ('Введите Y: ');

   Readln (y);

   if (y >= 1.2) and (y <= 2.5) then

     f := Sin (y)

   else

     f := Power (y, 3) - 0.5;

   Writeln ('y = ' + FloatToStr (f));

end;

Ответил hello93
0

P.S программа написана для Pascal

program fun;

function f( a: real): real;

var x:real;  

begin

 if (a<1.2) or (a>2.5) then

   x:=a*a*a-0.5;

 if (a>=1.2) and (a<=2.5) then

   x:=sin(a);

 f:=x;  

end;

var

 y: real;

begin

 writeln('Введите y');

 read(y);

 writeln('f=',f(y):0:2);    

end.



Новые вопросы