Информатика, вопрос задал mrkotukofficial , 2 года назад

Помогите составить программу.

Вводятся 2 числа a и b. Где а- натуральное число, b-число от 1 до 9. С помощью цикла найти сколько раз число b встречается внутри числа а.

Пример:

а=3464 b=4

Результат 2 (раза)


Через Паскаль.

Var
Begin Readln и тд


mrusipusi: можно питон

Ответы на вопрос

Ответил nastikots
1

Ответ:

program z1;

var a,b,k: integer;

begin

k:=0;

write ('a = ');

read(a);

write ('b = ');

read(b);

while a > 0 do

begin

if a mod 10 = b then k:=k+1;

a:=a div 10

end;

write('Результат ',k)

end.

Объяснение:

Вводим числа

Цикл с предусловием

Если последняя цифра числа а равна числу b, то значение k увеличиваем на 1

Изменяем значение а, на целый результат деления на 10

Вывод значения k

mod - остаток от целочисленного деления

div - целочисленное деление

Новые вопросы