Информатика, вопрос задал Illya227 , 8 лет назад

Помогите составить программу в С++: Создать функцию square (x) нахождение его площади квадрата и функцию maxi (x, y) нахождение наибольшего из двух значений. Дано сторону квадрата. Составить программу с использованием функции square и maxi, которая для двух квадратов, будет находить тот, площадь которого больше и выводить значение большей площади на экран.

Ответы на вопрос

Ответил Аноним
0
#include <iostream>
using namespace std;

double square(double x) {
   return x*x;
}

double maxi(double x, double y) {
  if (x>y)
     return x;
  else
     return y;
}

int main() {
   double a1,a2,s1,s2;
   cin >> a1 >> a2;
   cout << "s=" << maxi(square(a1),square(a2)) << endl;
   return 0;
}
Ответил Illya227
0
Большое спасибо
Ответил Аноним
0
Пожалуйста
Новые вопросы