Информатика, вопрос задал Kanyewest1488 , 10 лет назад

Помогите составить программу в Paskal!

 

1) Вычислите значение минимального элемента массива

2) Вычислите сумму минисального и максимального элементов

3) Выведите номер минимального элемента

4) Выведите номера максимальных элементов и их количество

Ответы на вопрос

Ответил goltgolt
0
Номера минимума и максимума не получается сделать паскаль выделывается чо то
var a: array[1..5] of integer; i,min,max,summa,nmin,nmax:integer;begin
for i:= 1 to 5 do readln(a[i]);
min:=a[1];for i:= 2 to 5 dobeginif a[i]<a[1] then begin min:=a[i];end;
end;
max:=a[1];for i:= 2 to 5 dobeginif a[i]>a[1] then max:=a[i];end;summa:=min+max;
writeln('min=',min);writeln('min+max=',summa);writeln('nomer min=',nmin);writeln('nomer mmax=',nmax);
end.
Новые вопросы