Информатика, вопрос задал ruslan650628 , 8 лет назад

Помогите составить программу в Pascal ABC !

Дано натуральное число
1)Программа, которая находит сумму цифр этого числа
2)которая определяет, что число начинается и заканчивается одной и той же цифрой

Ответы на вопрос

Ответил Duffeder
0
var a,b,n,sum: longint;
begin
read (n);  
b:= n mod 10;
while n>0 do  
begin  
if n div 10 = 0 then    
a:= n mod 10;    
sum:= sum + (n mod 10);  
n:= n div 10;  
end;  
writeln (sum);
if a = b then  write ('First digit = Last Digit')
else  
write ('First digit <> Last Digit');
end.
Ответил mihaflash
0
1 2 3 4 5 6 7 8 9 10 11 12 13 14 var i, sum, n, code:integer;  s:string; begin write('Введите натуральноее число: '); read(s); for i := 1 to Length(s) do begin Val(s, n, code); sum := sum + n; end; writeLn('Сумма цифр: ', sum); str(sum, s); if s[1] = s[Length(s)] then write('Число начинается и заканчивается одной цифрой ',
Новые вопросы