Помогите составить программу string 3,буду очень благодарна,очень срочно нужно.
Вот условие: Имеется строка текста. Требуется написать программу, которая зашифровывала бы ее в другую строку — заменяя каждый символ текста символом, следующим по порядку в таблице ASCII. Тогда слово КОТ превратится в слово ЛПУ. Требуется составить и программу дешифровки.
Использовать функции для работы с символами: chr и ord pascal.
НО ЧТОБ ОНА БЫЛА СОСТАВЛЕНА НАПОДОБИЕ ЭТОЙ ЗАДАЧИ
Приложения:

Ответы на вопрос
Ответил Вованичикчка
0
var s, encoded_s: string;
i: integer;
begin
write('Введите строку: ');
readln(s);
for i:=1 to length(s) do
encoded_s:=encoded_s + chr(ord(s[i]) + 1);
writeln(encoded_s);
end.
Ответил sidorkina2703
0
Спасибо огромное,а что означает encoded_s?
Ответил Вованичикчка
0
Это просто название переменной, в которой хранится "зашифрованная" строка
Ответил Вованичикчка
0
Можете назвать ее по-своему
Ответил sidorkina2703
0
Ещё раз спасибо)))
Ответил Вованичикчка
0
Не за что
Новые вопросы
Українська мова,
2 года назад
Русский язык,
2 года назад
Литература,
7 лет назад
Литература,
9 лет назад