Помогите, составить программу рост и вес среднестатистического учащегося в
Pascal ABC
Ответы на вопрос
Ответил ihorsyrota
0
const n=3; //к-во учеников
var i:integer;
sr,sw:real;
r:array[1..n] of integer;
w:array[1..n] of integer;
begin
sr:=0;
sw:=0;
for i:=1 to n do
begin
write('Рост ',i,' ученика: ');
readln(r[i]);
sr:=sr+r[i];
write('Вес ',i,' ученика: ');
readln(w[i]);
sw:=sw+w[i];
end;
sr:=sr/n;
sw:=sw/n;
writeln;
writeln('Средний рост ученика: ',sr:5:2);
writeln('Средний вес ученика: ',sw:5:2);
end.
var i:integer;
sr,sw:real;
r:array[1..n] of integer;
w:array[1..n] of integer;
begin
sr:=0;
sw:=0;
for i:=1 to n do
begin
write('Рост ',i,' ученика: ');
readln(r[i]);
sr:=sr+r[i];
write('Вес ',i,' ученика: ');
readln(w[i]);
sw:=sw+w[i];
end;
sr:=sr/n;
sw:=sw/n;
writeln;
writeln('Средний рост ученика: ',sr:5:2);
writeln('Средний вес ученика: ',sw:5:2);
end.
Ответил Аноним
0
Пожалуйста, указывайте версию языка Паскаль, если программа не может быть выполнена в любой из его версий. В вашем случае комментарии // не являются допустимыми во всех версиях языка.
Ответил Аноним
0
Лучше всего в первой строке пишите что-то типа // Pascal ABC
Ответил ihorsyrota
0
Окей, понял, спасибо.
Ответил Аноним
0
Школьники пытаются запускать программы, копируя их отсюда, а потом, если компилятор выдает ошибку, помечают решение неверным.
Новые вопросы
Математика,
2 года назад
Геометрия,
2 года назад
Химия,
9 лет назад
Математика,
9 лет назад
Математика,
10 лет назад