Информатика, вопрос задал zolbooemujin4 , 1 год назад

Помогите составить программу решения задач на Паскале :)))
Вариант 1 (#1-5) щ

Приложения:

ForeignAgent: за 5 баллов помогу одну любую из 5
sergotimi00: решать ?

Ответы на вопрос

Ответил sergotimi00
0

Ответ:

var a:integer;

m:string;

begin  

repeat

repeat  

writeln('длина и площадь(1), сумма и произведение 5 чисел(2),найти площадь 2-х кругом с радиусом r1 и r2 и вывести большую s(3),2 числа(4),точка(5).');

readln(a);

until a<=5;

case a of

1:begin  

var r,c,s:real;

 writeln('введите R');

 readln(r);

 c:=2*3.14*r;//длина окружности

 s:=3.14*sqr(r);//площадь круга

  writeln('площадь=<',c,'>');

 writeln('S=<',s,'>');

 end;

2:begin

var z1,z2,z3,z4,z5,summ1,summ2:real;

writeln('введите 5 чисел через <enter>');

readln(z1,z2,z3,z4,z5);

summ1:=z1+z2+z3+z4+z5;

summ2:=z1*Z2*Z3*z4*z5;

writeln('сумма=<',summ1,'>');

writeln('произведение=<',summ2,'>');

end;

3:begin

var s,r:real;

writeln('введите R');

readln(r);

s:=3.14*sqr(r);

writeln('S=<',s,'>');

end;

4:begin

var i,u:real;

repeat

writeln('Введите 2 числа через <enter>');

readln(i);

readln(u);

 if (i>u) then

 begin

 i:=i/3;

 u:=u*3;

 end

 else if (u>i)then

 begin

 u:=u/3;

 i:=i*3;

 end

 else until u<>i;

 writeln(i);

 writeln(u);

end;

5:begin

var p,l:real;

writeln('введите а,b через <enter>');

readln(p,l);

 p:=3*p+4;

 if (p=l) then writeln('принадлежат')

 else writeln('не пренадлежат');

end;

end;

writeln('выключит y/n');

readln(m);

until m='y';

end.

Объяснение:

Новые вопросы