Помогите составить программу, пожалуйста, нужно очень срочно!
Пятиугольник ABCDE задан координатами своих вершин (X1,Y1)(X2,Y2)(X3,Y3)(X4,Y4)(X5,Y5) соответственно. Найти площадь этого пятиугольника используя в качестве подпрограммы a) функцию
Ответы на вопрос
#include <iostream>
using namespace std;
struct my{
int x;
int y;
}
void S_size() ;
int main()
{
my my_struct = new my[5];
for(int i =0 ;i<5;i++)
{
cin >> my_struct[i].x;
cin >> my_struct[i].y;
}
S_size();
}
S_size()
{
double S = 0.5*((my_struct[0].x*my_struct[1].y)-(my_struct[1].x *my_struct[0].y))*((my_struct[1].x * my_struct[2].y)-(my_struct[2].x*my_struct[1].y))*((my_struct[2].x * my_struct[3].y)-(my_struct[3].x*my_struct[2].y))*((my_struct[3].x * my_struct[4].y)- (my_struct[4].x*my_struct[3].y));
cout << S ;
}