Информатика, вопрос задал Аноним , 2 года назад

Помогите составить программу по вычислению функции в TURBP PASCAL
Задание на скриншоте

Текст программы может выглядеть следующим образом:
Program Lab_2-1;
Uses CRT; { Раздел объявления внешних модулей }
Label M1,M2;
var
n : integer;
x,y : real;
p: byte; {Признак выполнения пунктаN1}
begin
clrscr; { Очистка экрана }
riteln(‘Программа вычисления функции…’);

{ Вывод на экран меню }
writeln(‘+--------------------------------------------+’);
writeln(‘| 1. Ввод данных |’);
writeln(‘| 2. Вычисление функции и вывод результатов |’);
writeln(‘| 3. Завершение работы программы |’);
writeln(‘+--------------------------------------------+’);
p:=0;
M1: riteln(‘введите пункт меню’);
readln(n); { Ввод номера пункта меню}
case n of
1: begin { Ввод данных }
M2: write(‘Введите значение аргумента x=’);
readln(x)

{ Проверка допустимого значения аргумента }
if x=0 then begin
riteln(‘x не может быть равным 0 по условию’) ;
goto M2; end;
p:=1; {Пункт N1 выполнен}
end;
2: { Вычисление значения функции }
begin
If p<>0 then
Writeln (‘Данные не введены, выполните пункт N1’);
else
begin
{ Операторы вычисления и вывода значения функции }
if x>0 then y:=1/x else y:=x*x;
writeln(‘при х=’, x:7:2, ‘ y=’, y:7:2)
end;
end;
3: Exit { Выход из программы }
end; { end case }
goto M1;
end. { Конец программы}

Приложения:

Ответы на вопрос

Ответил frants8080
0

Ответ:

User CRT;

Var x, y:real;

BEGIN

ClrScr;

Write('Введите значение функции x=');

ReadLn(x);

if x<0 then y:=x*x+4*x-8 else y:=1/(x*x+4*x-8);

WriteLn('при x=', x:7:2, 'y =', y:7:2);

END.

Объяснение:

Новые вопросы