Информатика, вопрос задал Scalp228 , 8 лет назад

Помогите составить программу по паскалю!
Определить количество чисел с цифрой 4 в записи числа

Ответы на вопрос

Ответил maksview
0
var
  ar:array[1..2000] of integer;
  n,i,count:integer;
begin
  readln(n);
  for i:=1 to n do begin
    read(ar[i]);
    while ((ar[i]>0) and ((ar[i] mod 10)<>4)) do ar[i]:=ar[i] div 10;
    if ar[i] mod 10 = 4 then inc(count);
  end;
  writeln(count);
end.
Новые вопросы