Помогите составить программу по информатике.
Дано предложение. Вычислить сколько в нем разных(неповторяющихся) знаков препинания.
Ответы на вопрос
Ответил zhoramalushevpegkpk
0
Пример решения задачи на языке PascalABC:
var
J:Array of Char:=('.','!','?',',',';',':','-','(',')','"');
T:=0;
begin
var s:string; readln(s);
var N:=S.ToCharArray;
for var l:=1 to J.High do
if N.FindAll(x->(x = J[l]) = true).Length <> 0 then inc(T);
write('В предложении ',(T<>0)? T.ToString:'не содержится',' уникальных знаков препинания');
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Алгебра,
2 года назад
Математика,
2 года назад
Литература,
8 лет назад
Математика,
8 лет назад