.Помогите составить программу на паскале:)
Для десяти чисел введенных с клавиатуры все отрицательные сложить а положительные умножить
антагонист:
а если число ровно нулю?
Ответы на вопрос
Ответил антагонист
1
var a,b,c,d:integer;
beginwriteln('введите десять чисел');
readln(a);
b:=1;
d:=0;
for c:=2 to 10 do
begin
readln(a);
if (a > 0) then b:=b*a;
if (a < 0) then d:=d+a;
end;
writeln('положительные ',b);
writeln('отрицательные ',d)
end.
beginwriteln('введите десять чисел');
readln(a);
b:=1;
d:=0;
for c:=2 to 10 do
begin
readln(a);
if (a > 0) then b:=b*a;
if (a < 0) then d:=d+a;
end;
writeln('положительные ',b);
writeln('отрицательные ',d)
end.
begin
writeln('введите 10 чисел');
readln(a);
b:=1;
d:=0;
c:=0;
while (c<>9) do
begin
c:=c+1;
if (a > 0) then b:=b*a;
readln(a);
if (a < 0) then d:=d+a;
end;
writeln('положительные ',b);
writeln('отрицательные ',d)
end.
Ответил xDmitryINFO
1
const
N = 10;
var
x, i, minus, plus:integer;
begin
plus:=-1;
minus:=0;
for i:=1 to N do
begin
readln(x);
if x<0 then
minus:=minus+x;
if x>0 then
if plus = -1 then
plus:=x
else
plus:=plus*x;
end;
writeln('Сумма отрицательных чисел: ', minus);
if plus = -1 then
writeln('Положительных чисел нет')
else
writeln('Произведение положительных чисел:', plus);
end.
N = 10;
var
x, i, minus, plus:integer;
begin
plus:=-1;
minus:=0;
for i:=1 to N do
begin
readln(x);
if x<0 then
minus:=minus+x;
if x>0 then
if plus = -1 then
plus:=x
else
plus:=plus*x;
end;
writeln('Сумма отрицательных чисел: ', minus);
if plus = -1 then
writeln('Положительных чисел нет')
else
writeln('Произведение положительных чисел:', plus);
end.
Новые вопросы
Другие предметы,
1 год назад
Английский язык,
1 год назад
Математика,
2 года назад
Русский язык,
2 года назад
История,
7 лет назад
История,
7 лет назад