Информатика, вопрос задал Rai4y , 8 лет назад

Помогите составить программу которая задает вопрос: "В каком году был основан город Минск" (например: в 1067 г., либо в 1147 г .,). В случае верного ответа программа должна сообщить (Верно), в противном случае - (вы ошиблись)

Ответы на вопрос

Ответил foursquare
0
С использованием кейсов. 
Приложения:
Ответил Rai4y
0
а если без кейсов 8 класс информатика?
Ответил foursquare
0
"begin и end." - тело программы, между ними выполняется весь код. "var input:smallint" - объявление локальной переменной с именем input и типом smallint(максимальное значение примерно 34к) Далее. writeln() выводим заданный текст. readln(input)
Ответил foursquare
0
readln(input) - записываем введенные данные с клавиатуры в переменную input. Далее "case input of" проверяем значение переменной input. Ниже до "end;" все возможные варианты ввода.
Ответил foursquare
0
Можно так же указать любой другой и вывести текст исходя из ответа.
Например: Если ввели 1067 выводится текст 'Верно'. "else" это если не один из вариантов не подошел.
Ответил foursquare
0
То есть до else можно указать например: 1066 и вывести 'Вы почти угадали'.
Новые вопросы