помогите составить программу ,которая позволяет вводить с клавиатуры элементы массива a[1..10] и числа k1 и k2(1<k1<k2<10),а затем выводит на экран в одну строку элементы массива с индексами от k1 до k2
пример ввода
11 12 13 14 15 16 17 18 19 20(элементы массива)
4(k1 число)
7(k2 число)
вывод на экран
14 15 16 17
Ответы на вопрос
Ответил GuitarMan
0
Ловите на паскале, если будет нужно на другом языке - пишите:
var mass: Array[1..10] of integer;
i, k1, k2: integer;
begin
for i := 1 to 10 do begin
write('Введите ', i, ' элемент массива: ' );
readln(mass[i]);
end;
write('Введите k1 и k2: ' );
readln(k1, k2);
writeln('======');
for i := k1 to k2 do begin
writeln(mass[i]);
end;
end.
var mass: Array[1..10] of integer;
i, k1, k2: integer;
begin
for i := 1 to 10 do begin
write('Введите ', i, ' элемент массива: ' );
readln(mass[i]);
end;
write('Введите k1 и k2: ' );
readln(k1, k2);
writeln('======');
for i := k1 to k2 do begin
writeln(mass[i]);
end;
end.
Новые вопросы