Информатика, вопрос задал РайВаду , 8 лет назад

Помогите составить программу, которая по сумме цифр определит делится ли число на 3.....

Ответы на вопрос

Ответил ShirokovP
0
function Div3(n:longint):boolean;
var s:byte;
begin
s:=0;
while n>0 do 
begin 
s:=s+n mod 10; 
n:=n div 10; 
end;
if s mod 3=0 then Div3:=true
else Div3:=false;
end;

var a:longint;
begin
write('Введите a: ');
readln(a);
if Div3(a) then write('Число делится на 3')
else write('Число не делится на 3');
end.
Новые вопросы