Информатика, вопрос задал ftuzix34 , 2 года назад

Помогите составить программу которая найдёт в линейном массиве сумму отрицательных элементов через генератор случайных чисел числа: [-40;50]
Помогите очень прошу я в информатике- ноль

Ответы на вопрос

Ответил kalach0
0

Ответ:

var i,s: integer;

a: array [1..10] of integer;

begin

write('Массив ');

for i:=1 to 10 do

begin

a[i]:=random(71)-30;

write (a[i]:4);

if a[i]>0 then s:=s+a[i]

end;

writeln;

write('Сумма положительных элементов массива ',s)

end.

Объяснение:

a[i]:=random(71)-30 если от -30 до 40 включительно

A[i]:= random (70)-30 если от -30 до 39 включительно

я не знаю правельна или неправельна

Новые вопросы