Информатика, вопрос задал zlatasifurova , 9 лет назад

Помогите составить программу для вычисления выражения на паскале

Приложения:

Ответы на вопрос

Ответил Аноним
0
var
  n,i:integer;
  a,an,s:real;
begin
  Write('Введите a и n: ');
  Read(a,n);
  s:=0;
  an:=1;
  for i:=0 to n do
  begin
    s:=s+(i+1)*an;
    an:=an*a
  end;
  Writeln('Ответ ',s)
end.

Результат выполнения программы
Введите a и n: 2.2 30
Ответ 1036213351740.38
Ответил Аноним
0
Замечание: "an" хранит значение "a" в степени, необходимой для выполнения следующего шага.
Ответил Аноним
0
Так экономнее, а кроме того, стандартный Паскаль не имеет операции возведения вещественного числа в степень.
Ответил Аноним
0
Точнее, в степень, не равную 2.
Новые вопросы