Информатика, вопрос задал евика , 8 лет назад

Помогите составить программу ..:Даны 3 отрезка,Определить существует ли треугольник.Если существует,то найти его площадь.Дано:a,b,c. Решение а+b больше с; b+cбольше а; с+а больше b. S=корень кв из P(p-a)(p-b)(p-c).

Ответы на вопрос

Ответил Veter0k
0
program HelloWorld;var a,b,c,s,p:double;begin    a:=3;    b:=4;    c:=5;    if((a+b>c) and (a+c>b) and (b+c>a))       then begin       p:=(a+b+c)/2;       s:=Sqrt(p*(p-a)*(p-b)*(p-c));       writeln(s);       end       else writeln('Error');end.
Ответил Nata9911
0
Язык C++.
Решение смотри во вложении.
Приложения:
Новые вопросы