Помогите составить программу C++ , срочнооооо(то что выделено)
Ответы на вопрос
Ответ:
Размерность массива (100)
Диапазон значений (-100 - +100)
Заменить все элементы с отрицательными значениями средним арифметическим значением всех положительных элементов
Объяснение:#include <iostream>
using std::cin;
using std::cout;
int main() {
double массив[100];
setlocale(LC_ALL, "Russian");
double среднее_арифметическое = 0, количество_цыфр_больше_нуля = 0;
cout<<"=> Было: \n";
for (int i=0; i<100; ++i)
{
массив[i] = rand()%200-100;
cout<<массив[i]<<"\n";
массив[i] > 0 ? ++количество_цыфр_больше_нуля, среднее_арифметическое+=массив[i] : NULL;
}
среднее_арифметическое/=количество_цыфр_больше_нуля;
cout<<"\n => Стало: \n\n";
for (int i=0; i<100; ++i){
массив[i] = массив[i] < 0 ? среднее_арифметическое : массив[i];
cout<<массив[i]<<"\n";
}
cin.ignore();
return EXIT_SUCCESS;
}
#include <iostream>
using namespace std;
int main()
{
int const n=100;
double a[n];
int kp=0;
double sp=0;
srand(time(0));
for(int i=0; i<n; i++)
{
a[i]= -100 + rand() % 201;
cout << a[i] << " ";
if(a[i]>0)
{
kp++;
sp+=a[i];
}
}
double avg=sp/kp;
for(int i=0; i<n; i++)
if (a[i]<0) a[i]=avg;
cout << endl;
for(int i=0; i<n; i++)
cout << a[i] << " ";
return 0;
}