Информатика, вопрос задал tdzemlyakov , 6 лет назад

Помогите составить код на python.
Задача:
Пользователь вводит n количество натуральных чисел(не больше 20). Программа должна обработать эти числа и вывести из них самое большое, кратное 5.
Попрошу написать программу максимально просто)​

Ответы на вопрос

Ответил Lokki112
1

Ответ:

Объяснение:

n = int(input()) # кол-во чисел на вход

var = 0

max_ = 0

for i in range(n + 1):

   var = int(input())

   if var % 5 == 0 and var > max_:

       max_ = var

       

print(max_)

Приложения:

tdzemlyakov: огромное спасибо, настрогал вроде тоже самое, но не получилось, ваше работает)
tdzemlyakov: только вопрос, почему после range идёт (n+1) если нам нужно обрабатывать n чисел?
Lokki112: потому что range работает так. Пусть n = 5
тогда range будет считать числа вот так ( 0 , 1 , 2 , 3 , 4)
я написал n + 1 , чтобы было так ( 0, 1 , 2 ,3 ,4 ,5 )
Lokki112: > огромное спасибо, настрогал вроде тоже самое, но не получилось, ваше работает)
может забыли отступы?
Новые вопросы