Информатика, вопрос задал olegshtukkert07 , 6 лет назад

ПОМОГИТЕ СДЕЛАТЬ ЗАДАЧУ НА ПИТОНЕ!!!
Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0

Ответы на вопрос

Ответил daraprelj
0

sum=0

num=0

i=int(input())

if i%8==0:

   sum+=i

   num+=1

while i!=0:

   i=int(input())

   if i%8==0:

       sum+=i

       num+=1

if sum==0:

   print("NO")

else:

   print("Среднее арифметическое = ",sum/(num-1))

Новые вопросы