Информатика, вопрос задал Ivan2k4 , 7 лет назад

Помогите сделать :

1)Исправить ошибки в программе , которая определяет количество отрицательных элементов .массива:


Program M;

Const

N=10;

Var

A: Array[1..N] of integer

I,k:integer;

Begin

For I:=1 To N Then

A[I]:=Random100-50;

if A[i]<0 do k:=k+1

End;

Write(k=,k);

End


2)Расставить в правильном порядке строчки программы , которая находит сумму всех четных элементов массива :


Program M;

constN=10;

Var

S:=0;

I,s : integer;

Begin

If A[i] mod 2=0 then S:=s+A[i];

A[i]:= Trunc Random (101)-50;

End;

For I:=1 To N Do begin


A:Array [1..N] of integer;

Write('s=',s);

End.


3)Написать программу , которая посчитает сумму баллов заработанных командой из 10 человек интеллектуальном турнире по химии . Баллы для каждого участника указать рандомными числами в диапазоне от 5 до 20

Ответы на вопрос

Ответил defendercryak
0

1) Program M;

Const N=10;

Var A: Array[1..N] of integer;

I,k:integer;

Begin

For I:=1 To N do begin

A[I]:=Random100-50;

if A[i]<0 then k:=k+1

End;

Write(k=,k);

End.

2)Program M;

const N=10;

Var A:Array [1..N] of integer;

I,s : integer;

Begin

S:=0;

For I:=1 To N Do begin

A[i]:=Random (101)-50;

If A[i] mod 2=0 then S:=s+A[i];

End;

Write('s=',s);

End.

3) Program chemistry;

Const N=10;

Var A: Array[1..N] of integer;

S:integer;

Begin

For I:=1 To N do begin

A[I]:=Random(16)+5;

s:=s+a[i];

End;

Write(s=,s);

End.

Новые вопросы