Помогите с заданием по информатике
"Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате даст произведение этих чисел (используя два вида циклов)"
*на паскале*
Ответы на вопрос
Ответил FreeProgrammer
0
В Паскале имеется три вида стандартных циклов:
1) цикл с параметром (цикл for ... to ... do ...)
2) цикл с предусловием (цикл while ... do ...)
3) цикл с постусловием (цикл repeat ... until ...)
Программа с использованием цикла с параметром:
program z1;
var i:integer;
x,p:real;
begin
p:=1; {задаем начальное значение произведения}
for i:=1 to 10 do {указываем количество повторений}
begin
readln(x); {вводим очередное число х}
p:=p*x; {умножаем введенное число х к произведению р}
end;
writeln(p); {вывод результата}
end.
Программа с использованием цикла с предусловием:
program z1;
var i:integer;
x,p:real;
begin
p:=1; {задаем начальное значение произведения}
i:=1; {задаем начальное значение счетчика}
while i<=10 do {задаем условие повторения цикла: пока i<=10}
begin
readln(x); {вводим очередное число х}
p:=p*x; {умножаем введенное число х к произведению р}
i:=i+1; {увеличиваем счетчик i на единицу}
end;
writeln(p); {вывод результата}
end.
Программа с использованием цикла с постусловием:
program z1;
var i:integer;
x,p:real;
begin
p:=1; {задаем начальное значение произведения}
i:=1; {задаем начальное значение счетчика}
repeat {повторять все указанные действия}
readln(x); {вводим очередное число х}
p:=p*x; {умножаем введенное число х к произведению р}
i:=i+1; {увеличиваем счетчик i на единицу}
until i>10; {до тех пор, пока счетчик i не станет больше 10}
writeln(p); {вывод результата}
end.
1) цикл с параметром (цикл for ... to ... do ...)
2) цикл с предусловием (цикл while ... do ...)
3) цикл с постусловием (цикл repeat ... until ...)
Программа с использованием цикла с параметром:
program z1;
var i:integer;
x,p:real;
begin
p:=1; {задаем начальное значение произведения}
for i:=1 to 10 do {указываем количество повторений}
begin
readln(x); {вводим очередное число х}
p:=p*x; {умножаем введенное число х к произведению р}
end;
writeln(p); {вывод результата}
end.
Программа с использованием цикла с предусловием:
program z1;
var i:integer;
x,p:real;
begin
p:=1; {задаем начальное значение произведения}
i:=1; {задаем начальное значение счетчика}
while i<=10 do {задаем условие повторения цикла: пока i<=10}
begin
readln(x); {вводим очередное число х}
p:=p*x; {умножаем введенное число х к произведению р}
i:=i+1; {увеличиваем счетчик i на единицу}
end;
writeln(p); {вывод результата}
end.
Программа с использованием цикла с постусловием:
program z1;
var i:integer;
x,p:real;
begin
p:=1; {задаем начальное значение произведения}
i:=1; {задаем начальное значение счетчика}
repeat {повторять все указанные действия}
readln(x); {вводим очередное число х}
p:=p*x; {умножаем введенное число х к произведению р}
i:=i+1; {увеличиваем счетчик i на единицу}
until i>10; {до тех пор, пока счетчик i не станет больше 10}
writeln(p); {вывод результата}
end.
Новые вопросы