Информатика, вопрос задал belandr55 , 2 года назад

Помогите с задачей по информатике в паскале, пожалуйста
Нужно написать программу.

Приложения:

Ответы на вопрос

Ответил huston81
0

Ответ:

program thegame;

var

 itog, player1, player2, score: integer;

begin

 Write('Введите кол-во очков, до которых играем: '); Readln(itog);

 while (player1 < itog) and (player2 < itog) do

 begin

   score := round(random(100));

   WriteLn('Выпало число ', score, '. ');

   if (score mod 3 = 0) and (score mod 5 = 0) then

   begin

     WriteLn('Оно кратно и 3, и 5, значит никто очков не получает.');

     continue;

   end;

   if score mod 3 = 0 then

   begin

     player1 := player1 + 1;

     WriteLn('Оно кратно 3, значит Вася получает очко. У него сейчас ', player1, ' очков.');

   end;

   if score mod 5 = 0 then

   begin

     player2 := player2 + 1;

     WriteLn('Оно кратно 5, значит Петя получает очко. У него сейчас ', player2, ' очков.');

   end;

 end;

 if player1 = itog then WriteLn('ПОБЕДИЛ ВАСЯ !!!') else WriteLn('ПОБЕДИЛ ПЕТЯ !!!');

end.

Объяснение:

Новые вопросы