Помогите с задачей, необходимо написать программу по данной блок схеме.
программу на языке паскаль
Приложения:


Ответы на вопрос
Ответил petyaGavrikov
0
var a,b,c:real; k:integer;
begin
readln(a,b,c);
k:=1;
repeat
b:=b*2;
a:=a-b/2;
if a<=0
then writeln('Чёрт разорён')
else begin
a:=a+c;
b:=b-c;
if b<=0 then writeln('Мужик разорён')
else k:=k+1;
end;
until (a<=0)or(b<=0);
writeln(k);
end.
Пример:
15 12 4
Чёрт разорён
2
begin
readln(a,b,c);
k:=1;
repeat
b:=b*2;
a:=a-b/2;
if a<=0
then writeln('Чёрт разорён')
else begin
a:=a+c;
b:=b-c;
if b<=0 then writeln('Мужик разорён')
else k:=k+1;
end;
until (a<=0)or(b<=0);
writeln(k);
end.
Пример:
15 12 4
Чёрт разорён
2
Ответил Аноним
0
А можно "детский" вопрос? Если на блок-схеме не было блока вывода приглашения writeln('a, b, c:'); откуда он появился у Вас?
Новые вопросы