Информатика, вопрос задал galviktor2016 , 10 лет назад

Помогите с задачей!
напишите программу определения стоимости разговора по телефону с учётом скидки 20% представляемой по субботам и воскресениям. Вычисление стоимости разговора по телефону. Введите исходные данные: Длительность разговора(целое количество минут)— 3 День недели(1-понедельник,...7-воскресенье)--5 Предоставляется скидка 20% Стоимость разговора: 5.52 руб. (она большая должна быть и для паскаля)!

Ответы на вопрос

Ответил karimPhoenix
0
program D1KPxx3;
uses crt;
var
i:integer;
min,rez:real;
b:char;
label 1,2;
begin
1:write('Введите время разговора');
read(min);
writeln('Введите номер дня недели');
read(i);
if (i=6) or (i=7) then
begin
rez:=((min*5.52)-(min*0.2));
write('Стоимость разговора с учетом скидки равна: ',rez);
goto 2;
end
else
rez:=min*5.52;
write('Стоимость разговора равна: ',rez);
2:writeln('Ещё??  Y/N');
readln(b);
if b='Y' then
goto 1;
if b='N' then
write('Пока!');
end.
Ответил galviktor2016
0
кстати что такое rez?)
Ответил karimPhoenix
0
это результат, сколько стоить будет!)
Ответил galviktor2016
0
Спасибо)
Ответил karimPhoenix
0
всегда пожалуйста)
Ответил galviktor2016
0
))
Новые вопросы