Информатика, вопрос задал PolniyBezsar , 1 год назад

Помогите с задачами по информатике пожалуйста! Язык Python
1.На вход программы поступает неизвестное количество целых чисел, ввод заканчивается 0. Определить сколько получено чисел, которые делятся на 3.
2.Написать программу, которая находит количество четырехзначных чисел, которые делятся на 7.
3. Задумано трехзначное число, которое при делении на 15 даёт в остатке 11, а при делении на 11 даёт в остатке 9. Напишите программу, которая находит все такие числа.

Ответы на вопрос

Ответил Аноним
1

1.Решение задачи на Python:

count = 0  # инициализируем счетчик чисел, делящихся на 3

while True:

   num = int(input("Введите число: "))

   if num == 0:

       break  # если введено 0, выходим из цикла

   if num % 3 == 0:

       count += 1  # если число делится на 3, увеличиваем счетчик

print("Количество чисел, делящихся на 3:", count)

2.Решение задачи на Python:

count = 0  # инициализируем счетчик чисел, делящихся на 7

for i in range(1000, 10000):

   if i % 7 == 0:

       count += 1  # если число делится на 7, увеличиваем счетчик

print("Количество четырехзначных чисел, делящихся на 7:", count)

3.Решение задачи на Python:

for num in range(100, 1000):

   if num % 15 == 11 and num % 11 == 9:

       print(num)

Эта программа перебирает все трехзначные числа и проверяет, удовлетворяют ли они условию, описанному в задаче. Если число удовлетворяет условию, оно выводится на экран.


PolniyBezsar: Благодарю вас!
Новые вопросы