Информатика, вопрос задал OlegTretyakov , 7 лет назад

Помогите с Python, пж!
Напишите программу для подсчета количества дней, в которых температура была не ниже, чем средняя температура за весь период. В первой строке вводится список показателей температуры на каждый день. В строке вывода одно число - количество дней, которые соответствуют условию.

К примеру, Ввод:
-3 -1 0 2 6 8 12 15
Вывод:
4

Ответы на вопрос

Ответил tutu007
1

Ответ:

massiv=input()

massiv=list(map(int,massiv.split(" ")))

sr=sum(massiv)/len(massiv)

count=0

for i in range(len(massiv)):

   if massiv[i]>=sr:

       count+=1

print(count)

Новые вопросы