Информатика, вопрос задал OlegTretyakov , 7 лет назад

Помогите с Python!
Напишите программу, на вход которой непрерывно (в цикле) подаются введены пользователем данные. При введении каких-либо данных, кроме целых чисел, выводится сообщение об ошибке с помощью генерирования исключения ValueError. Как только ввели целое число, выводится сообщение True и происходит выход из программы.

Ответы на вопрос

Ответил CarabasJirobas
1

прикрепляю файл с рабочим кодом. При желании можно в  блоке except в строке print ввести любое выражение, которое должно появляться при некорректном значении.

while True:

   x=input()

   try:

       x=int(x)

       print('True')

       break

   except ValueError:

       print('ValueError')


OlegTretyakov: Спасибо!)
Новые вопросы