Информатика, вопрос задал tigor71 , 1 год назад

ПОМОГИТЕ С ПИТОНОМ!! ДАЮ 20 БАЛЛОВ
Напишите программу, которая умеет выбирать все самое притягательное, то есть такое, что заканчивается на гласную букву (аяоёэеуюиы) в любом регистре.

Формат ввода
Вводится строка-разделитель. Затем вводится строка фраз через этот разделитель.

Формат вывода
Через двоеточие и пробел вывести фразы, которые заканчиваются на гласную букву.

Приложения:

Ответы на вопрос

Ответил Аноним
0

Объяснение:

Использовал функции из стандартной библиотеки Python, главным образом функцию split(). В ее параметр добавил строку, которая становится разделителем(по умолчанию - пробел). Ну и дальше несложный алгоритм через использование цикла, в котором проверяем каждую фразу на удовлетворение условия.

Код Python 3.10.

delim = input().strip()

input_str = input().strip().split(delim)

vowels = ('a', 'у', 'о', 'и', 'э', 'ы', 'я', 'ю', 'е', 'ё')

res = []

for s in input_str:

   if s[-1].lower() in vowels:

       res.append(s)

print(': '.join(res))

Новые вопросы