Помогите с паскалем, у меня практика, это очень срочно...
1. Вычислите выражение при заданных константах: A=16.5; b=3.4; x=0.61; 
2.
Составить программу вычисления значения функции. На экран вывести функцию (записанную на Паскале) вместе с результатом.
у={a+b+cx^2,если 1<=x<2
(a*sin(xb))^2,если 2<=x<3
под корнем |a+bx^2|+c ,если 3<=x<4
a*ln|b+c/2x| ,если 4<=x<5
e^esinx+c^3 ,если 5<=x<6
Пожалуйста...
Приложения:


Ответы на вопрос
Ответил nikolac
0
1)
uses crt;
const a=16.5;b=3.4;x=0.61;
var s,q:real;
begin
s:=x*x*x*(sin((x+b)*(x+b))/cos((x+b)*(x+b)))*(sin((x+b)*(x+b))/cos((x+b)*(x+b)))+a/sqrt(x+b);
q:=(b*x*x-a)/(power(e,a*x)-1);
writeln('s: ',s:0:4,' q: ',q:0:4);
end.
2)
uses crt;
const a=16.5;b=3.4;
var f,c,x:real;
begin
writeln('Введите c,x:');
read(c,x);
if (x<1) or (x>=6) then
writeln('NULL')
else if (x>=1) and (x<2) then
f:=a+b*x+c*x*x
else if (x>=2) and (x<3) then
f:=(a*sin(x*b))*(a*sin(x*b))
else if (x>=3) and (x<4) then
f:=sqrt(abs(a+b*x*x)+c)
else if (x>=4) and (x<5) then
f:=a*ln(b+c/(2*x))
else if (x>=5) and (x<6) then
f:=power(e,e*sin(x))+c*c*c;
writeln(f:0:4);
end.
uses crt;
const a=16.5;b=3.4;x=0.61;
var s,q:real;
begin
s:=x*x*x*(sin((x+b)*(x+b))/cos((x+b)*(x+b)))*(sin((x+b)*(x+b))/cos((x+b)*(x+b)))+a/sqrt(x+b);
q:=(b*x*x-a)/(power(e,a*x)-1);
writeln('s: ',s:0:4,' q: ',q:0:4);
end.
2)
uses crt;
const a=16.5;b=3.4;
var f,c,x:real;
begin
writeln('Введите c,x:');
read(c,x);
if (x<1) or (x>=6) then
writeln('NULL')
else if (x>=1) and (x<2) then
f:=a+b*x+c*x*x
else if (x>=2) and (x<3) then
f:=(a*sin(x*b))*(a*sin(x*b))
else if (x>=3) and (x<4) then
f:=sqrt(abs(a+b*x*x)+c)
else if (x>=4) and (x<5) then
f:=a*ln(b+c/(2*x))
else if (x>=5) and (x<6) then
f:=power(e,e*sin(x))+c*c*c;
writeln(f:0:4);
end.
Ответил KangEunRa
0
Большущее спасибо, вы меня спаслиииииииии!!!!
Новые вопросы