Помогите с Паскалем. Нужно написать программу, которая с помощью функции, выводит наибольшую цифру в введенном числе.
Ответы на вопрос
Ответил petyaGavrikov
0
var a:integer;
function max(n:integer):integer;
var m:integer;
begin
n:=abs(n);
m:=0;
while n<>0 do
begin
if n mod 10 > m then m:=n mod 10;
n:=n div 10;
end;
max:=m;
end;
begin
write('a = ');
readln(a);
writeln('Максимальная цифра = ',max(a));
end.
Пример:
a = -185
Максимальная цифра = 8
function max(n:integer):integer;
var m:integer;
begin
n:=abs(n);
m:=0;
while n<>0 do
begin
if n mod 10 > m then m:=n mod 10;
n:=n div 10;
end;
max:=m;
end;
begin
write('a = ');
readln(a);
writeln('Максимальная цифра = ',max(a));
end.
Пример:
a = -185
Максимальная цифра = 8
Ответил asigho
0
Спасибо огромное
Ответил petyaGavrikov
0
Пожалуйста. Пользуйтесь кнопочкой "Спасибо"
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!
function MaxDigit(n:int64):integer;
begin
Result:=0;
n:=Abs(n);
while n>0 do (Result,n):=(Max(Result,n mod 10),n div 10)
end;
begin
var n:int64;
Write('Введите число: '); Read(n);
Writeln('Максимальная цифра равна ',MaxDigit(n))
end.
Пример
Введите число: 340458239345
Максимальная цифра равна 9
// Внимание! Если программа не работает, обновите версию!
function MaxDigit(n:int64):integer;
begin
Result:=0;
n:=Abs(n);
while n>0 do (Result,n):=(Max(Result,n mod 10),n div 10)
end;
begin
var n:int64;
Write('Введите число: '); Read(n);
Writeln('Максимальная цифра равна ',MaxDigit(n))
end.
Пример
Введите число: 340458239345
Максимальная цифра равна 9
Новые вопросы