Информатика, вопрос задал legendpro2 , 8 лет назад

Помогите с Паскалем

1) 1. Даны катеты в двух прямоугольных треугольниках – a1, b1 и a2, b2. Определить, площадь какого треугольника больше и на сколько. Если площади равны, вывести фразу – «Треугольники равновелики». (Проверка: 5,6 и 2,15. Ответ: Треугольники равновелики. Ещё проверка: 7,5 и 6,9. Ответ: Площадь второго треугольника больше на 19).

2) 2. На автобусном билете есть номер, состоящий из шестизначного числа. Напишите программу, которая будет проверять счастливый ли билет? Билет считается счастливым, если сумма первых трёх цифр равна сумме трёх последних цифр. (Проверка: 365478. Ответ: Билет не счастливый. Ещё проверка: 385493. Ответ: Билет счастливый).

Ответы на вопрос

Ответил ruslol
0
1)
var a,b,a1,b1:real;
var s,s1:real;
begin
WriteLn('Введите все катеты через пробел:');
Read(a,b,a1,b1);
s:=a/2*b;
s1:=a1/2*b1;
WriteLn(s);
WriteLn(s1);
if s = s1 then
WriteLn('Треугольники равновелики')
else if s>s1 then
WriteLn('Площадь первого треугольника больше на '+(s-s1))
else
WriteLn('Площадь второго треугольника больше на '+(s1-s));
end.

2)
var a,b:Integer;
var arr:array of char;
begin
arr:=ReadString().ToCharArray();
for var i:= 1 to 6 do
if(i<4) then
a+= strtoint(arr[i-1])
else
b+= strtoint(arr[i-1]);
if a=b then
WriteLn('Билет счастливый')
else
WriteLn('Билет не счастливый');
end.
Новые вопросы