Помогите с Pascal Turbo. Нужно написать программуНаберите программу вычисления суммы S=X+X^2+...+X^n и проверьте ее работу при различных значениях X и натурального N
Ответы на вопрос
Ответил A1dar
0
var
s, cur: longint;
x, n, i: integer;
begin
write('x='); read(x);
write('n='); read(n);
cur := 1; s := 0;
for i := 1 to n do begin
cur := cur * x;
s := s + cur;
end;
writeln('sum=', s)
end.
s, cur: longint;
x, n, i: integer;
begin
write('x='); read(x);
write('n='); read(n);
cur := 1; s := 0;
for i := 1 to n do begin
cur := cur * x;
s := s + cur;
end;
writeln('sum=', s)
end.
Ответил A1dar
0
Проверить, думаю, сам сможешь
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Математика,
9 лет назад
Химия,
9 лет назад
Математика,
9 лет назад
Математика,
9 лет назад