Информатика, вопрос задал MSashaZ , 1 год назад

Помогите С++
Написать программу для чисел в диапазоне от A до B
определяло количество их делителей. К примеру, A = 10, B = 15.
Делители для числа 10 - 1 2 5 10;
Делители для числа 11 – 1 11;
Делители для числа 12 - 1 2 3 4 6 12;
Делители для числа 13 - 1 13;
Делители для числа 14 – 1 2 7 14;
Делители для числа 15 – 1 3 5 15.

Ответы на вопрос

Ответил Ergbertgb
0

Ответ:

#include <iostream>

#include <set>

void delim(int n) {

   std::set<int> tmp;

   std::cout << n << ": ";

   for (int i = 1; i <= sqrt(n); i++) {

       if (n % i == 0){

           tmp.insert(i);

           tmp.insert(n/i);

       }

   }

   for (auto x:tmp){

       std::cout << x << ' ';

   }

   std::cout << std::endl;

}

int main()

{

 int A, B;

 std::cin >> A >> B;

 for (int i = A; i<=B; i++) {

     delim(i);

 }

 

}

Объяснение:

Новые вопросы