Помогите с написанием программ в
Помогите с написанием программ в ПАСКАЛЕ
1) Если а>7, то найти сумму BC, иначе найти разность.
2) Определить квадрат числа, если оно положительное, но если отрицательное - куб.
3) Идет К-ая секунда суток. Напечатать сколько полных часов, минут и секунд прошло к данному моменту.
4) В магазине продается костюмная ткань. Ее цена В рублей за квадратный метр. Напишите программу, которая подсчитает и выведет на экран стоимость куска этой ткани, длиной Х метров и шириной 80 см.
Ответы на вопрос
Ответил ff923
0
1. program z;
var a,B,C,n:integer;
begin
writeln('Введите a,B,C'); read(a,B,C);
if a>7 then n:=B+C
else
n:=B-C;
writeln(n);
end.
var a,B,C,n:integer;
begin
writeln('Введите a,B,C'); read(a,B,C);
if a>7 then n:=B+C
else
n:=B-C;
writeln(n);
end.
Ответил SteelArtist
0
Можешь остальные сделать? Срочно нужно просто. Я все свои баллы потратил.
Ответил ff923
0
2.program z;
var a,b:integer;
begin
read(a);
if a>0 then b:=sqr(a)
else
b:=a*a*a;
writeln(b);
end.
var a,b:integer;
begin
read(a);
if a>0 then b:=sqr(a)
else
b:=a*a*a;
writeln(b);
end.
Ответил пчеламая
0
Var x, y: real;
Begin
Writen('введите число х=');
Readln(x);
If x>0 then y:=x*x
Else y:=x*x*x;
Writeln ('ответ' , y);
End.
Begin
Writen('введите число х=');
Readln(x);
If x>0 then y:=x*x
Else y:=x*x*x;
Writeln ('ответ' , y);
End.
Ответил пчеламая
0
H:=s div 3600; min:=(s mod 3600) div 60; sec:=(s mod 3600) mod 60;
Ответил пчеламая
0
H часов,min минут, sec секунд
Ответил пчеламая
0
Sorrу замени s на k
Ответил SteelArtist
0
Спасибо
Ответил пчеламая
0
Удачи!
Новые вопросы
История,
2 года назад
Биология,
2 года назад
Математика,
10 лет назад
Математика,
10 лет назад
История,
10 лет назад