Информатика, вопрос задал sosataos , 2 года назад

Помогите с информатикой срочно!

Составьте программу заполнения массива K(состоящего из 7 элементов), с помощью генератора случайных чисел вывести его в строку
1. Найти сумму всех элементов

2.Найти произведение элементов на чётных местах


pinguinbird: Какой язык программирования?
sosataos: паскаль

Ответы на вопрос

Ответил bekentaitomiris
0

Объяснение:

всё на фото

лайк пожалуйста

и лучший ответ ПЛИИИИТЗ

Приложения:

pinguinbird: к сожалению, данный код не выводит сумму элементов массива, а также произведение элементов, стоящих на четных местах. А также при выводе массива в конце будет запятая стоять, что тоже не очень хорошо
Ответил pinguinbird
1

Ответ:

program prgm;

var K:array[1..7] of integer;

   i,sum,mul:integer;

begin

   sum:=0;

   for i:=1 to 7 do begin

       K[i]:=random(10);

       if i = 2 then mul:=K[i]

       else if i mod 2 = 0 then mul:=mul * K[i];

       sum:=sum+K[i];

       write(K[i],' ');

   end;

   writeln();

   writeln('Сумма всех элементов массива равна: ', sum);

   writeln('Произведение элементов массива, стоящих на чётных местах, равно: ', mul);

end.

Новые вопросы