Помогите с информатикой,пожалуйста
Написать программу в Паскале,которая по координатам 2х введенных точек определяла бы четверть координатной плоскости,где они находятся(можно сделать через 4 if),а также длину отрезка между ними(используя функцию SQRT и формулу длины отрезка)
Ответы на вопрос
Ответил ProgrammerV1
0
uses crt;
var
x,y: real;begin
clrscr;
write ('x = '); read (x);
write ('y = '); readln (y); if (x > 0) and (y > 0) then
writeln ('Номер четверти координатной плоскости:I')
else
if (x < 0) and (y > 0) then
writeln ('Номер четверти координатной плоскости:II')
else
if (x < 0) and (y < 0) then
writeln ('Номер четверти координатной плоскости:III')
else
if (x > 0) and (y < 0) then
writeln ('Номер четверти координатной плоскости:IV')
else
if (x>0)or(x<0) and (y=0) then writeln ('-. Точка лежит на оси. X')
else
if (y>0)or(y<0) and (x=0) then writeln ('-. Точка лежит на оси. Y')
else writeln ('-. Точка лежит в центре.');readln
end.
var
x,y: real;begin
clrscr;
write ('x = '); read (x);
write ('y = '); readln (y); if (x > 0) and (y > 0) then
writeln ('Номер четверти координатной плоскости:I')
else
if (x < 0) and (y > 0) then
writeln ('Номер четверти координатной плоскости:II')
else
if (x < 0) and (y < 0) then
writeln ('Номер четверти координатной плоскости:III')
else
if (x > 0) and (y < 0) then
writeln ('Номер четверти координатной плоскости:IV')
else
if (x>0)or(x<0) and (y=0) then writeln ('-. Точка лежит на оси. X')
else
if (y>0)or(y<0) and (x=0) then writeln ('-. Точка лежит на оси. Y')
else writeln ('-. Точка лежит в центре.');readln
end.
Новые вопросы