Помогите с информатикой. Паскаль
1. Вычислить и напечатать значения функции y=6*x2-9*x для x от 1 до 10 с шагом в 1.
2. Написать программу, которая выводит целые числа в промежутке от 1 до 50, кратные двенадцати и считает их количество, сумму и произведение.
Ответы на вопрос
Ответил petyaGavrikov
0
1.
var x:integer;
begin
for x:=1 to 10 do
writeln(x:3,' ',6*x*x-9*x);
end.
Результат:
1 -3
2 6
3 27
4 60
5 105
6 162
7 231
2.
var i,k,s:integer; p:longint;
begin
k:=0;
s:=0;
p:=1;
for i:=1 to 50 do
if i mod 12=0 then
begin
write(i,' ');
k:=k+1;
s:=s+i;
p:=p*i;
end;
writeln;
writeln('k = ',k,' s = ',s,' p = ',p);
end.
Результат:
12 24 36 48
k = 4 s = 120 p = 497664
Новые вопросы