Помогите с иформатикой в системе Pascal
Составить программу
вывода на экран всех
элементов массива,
оканчивающихся
нулем.
Ответы на вопрос
Ответил Аноним
0
const
n=15;
var
a:array[1..n] of integer;
i:integer;
begin
Randomize;
Writeln('Исходный массив');
for i:=1 to n do begin
a[i]:=Random(35)+1;
Write(a[i],' ')
end;
Writeln;
Write('Элементы, оканчивающиеся нулем: ');
for i:=1 to n do
if a[i] mod 10=0 then Write(a[i],' ')
end.
Пример
Исходный массив
8 28 35 25 35 1 20 14 30 4 2 15 20 2 13
Элементы, оканчивающиеся нулем: 20 30 20
n=15;
var
a:array[1..n] of integer;
i:integer;
begin
Randomize;
Writeln('Исходный массив');
for i:=1 to n do begin
a[i]:=Random(35)+1;
Write(a[i],' ')
end;
Writeln;
Write('Элементы, оканчивающиеся нулем: ');
for i:=1 to n do
if a[i] mod 10=0 then Write(a[i],' ')
end.
Пример
Исходный массив
8 28 35 25 35 1 20 14 30 4 2 15 20 2 13
Элементы, оканчивающиеся нулем: 20 30 20
Новые вопросы