Информатика, вопрос задал dsadx1234 , 8 лет назад

Помогите с экзаменом Pascal:
1 задача: треугольник задан координатами своих вершин на плоскости. Составить программу, которая определит, является ли он равносторонним, равнобедренным или разносторонним
2 задача: Дано целое число N (N > 1). Найти наибольшее целое число i, при котором выполняется неравнество 3^i < N

Ответы на вопрос

Ответил DonPedro80
0
PascalABC.NET 3.4

function L(x1,y1,x2,y2:real):=Sqrt(Sqr(x2-x1)+Sqr(y2-y1));

begin
  var (xa,ya):=ReadReal2('Введите координаты точки А(х,у):');
  var (xb,yb):=ReadReal2('Введите координаты точки B(х,у):');
  var (xc,yc):=ReadReal2('Введите координаты точки C(х,у):');
  var a:=L(xb,yb,xc,yc);
  var b:=L(xc,yc,xa,ya);
  var c:=L(xb,yb,xa,ya);
  var k:=a=b?1:0;
  k+=a=c?1:0;
  k+=b=c?1:0;
  case k of
  0:Writeln('разносторонний');
  1:Writeln('равнобедренный');
  else Writeln('равносторонний');
  end
end.

****************

begin
  var n:=ReadInteger('n=');
  var i:=Trunc(Ln(n)/Ln(3));
  if 3**i=n then i-=1;
  Writeln(i)
end.
Новые вопросы