Информатика, вопрос задал mivary , 6 лет назад

Помогите с домашкой на паскале.
Напишите программу нахождения среднего арифметического минимального из кратных 3 и минимального из кратных 10 элементов массива A[1:30] заполненного произвольными числами в диапазоне [0,50].

Ответы на вопрос

Ответил vimmortal2
0

Программа:

Pascal:

const n = 30;  // кол-во элементов в массиве

var

 arr: array[1..n] of integer;

 i, minThree, minTen: integer;

begin

 minThree := MAXINT;

 minTen := MAXINT;

 for i := 1 to n do

 begin

   arr[i] := random(50);  // заполнение случайными числами от 0 до 50

   if (arr[i] mod 3 = 0) and (arr[i] < minThree) then  // если число кратно трём и оно меньше текущего минимального числа, то...

     minThree := arr[i];  // присвоить переменной minThree значение этой переменной

   if (arr[i] mod 10 = 0) and (arr[i] < minTen) then

     minTen := minThree;

 end;

 

 writeln('Массив: ', arr);

 writeln('Среднее арифметическое чисел (по условию): ', (minThree + minTen) / 2);

end.

Новые вопросы