ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ В ПАСКАЛЕ С ИСПОЛЬЗОВАНИЕМ ЦИКЛА С ПОСТУСЛОВИЕМ!!!
Составить программу запроса пароля пока не будет введён пароль верно. В программе предусмотреть счётчик неправильных вводов пароля.
Ответы на вопрос
Ответил iolandavalerypad353
0
var
parole, s: string;
Count: byte;
begin
parole := 'Земля прощай. В добрый путь!';
Count := 0;
repeat
Writeln('Введите пароль');
Readln(s);
Count += 1
until (s = parole) or (Count = 3);
if Count = 3 then
begin
Write('Вы не прошли индентификацию. Доступ закрыт');
Halt
end
else
Write('Доступ разрешен.')
end.
Ответил iolandavalerypad353
0
Цикл неправильно работает, нужно так:
Ответил iolandavalerypad353
0
repeat
Writeln('Введите пароль');
Readln(s);
if s <> parole then
Count += 1
until (s = parole) or (Count = 3);
Writeln('Введите пароль');
Readln(s);
if s <> parole then
Count += 1
until (s = parole) or (Count = 3);
Новые вопросы
Русский язык,
2 года назад
Геометрия,
7 лет назад
Обществознание,
7 лет назад
Математика,
9 лет назад
Литература,
9 лет назад